Categories
不学无术

PAT1037 Magic Coupon (25)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

 
=====================================================
这道题也没什么技术含量,就是给你一个X列一个Y列,里面要凑出最大的积的和。有个限制条件,就是商品数量有限,所以可以从商品入手。将商品、优惠券全部排序后,从商品的一段开始匹配能产生最大积的优惠券,累计和,如果碰到乘出负数的就掉个头,从末端往回找。因为求快,所以代码写的多了点,估计还能精简…

#include <iostream>
using namespace std;
int compare(const void *a, const void *b)
{
	return (*(long*)a > *(long*)b) ? -1 : 1;
}
int main()
{
	int NC, NP;
	cin >> NC;
	long * coupons = new long[NC];
	for (int i = 0; i < NC; i++)
	{
		cin >> coupons[i];
	}
	cin >> NP;
	long * products = new long[NP];
	for (int i = 0; i < NP; i++)
	{
		cin >> products[i];
	}
	qsort(coupons, NC, sizeof(long), compare);
	qsort(products, NP, sizeof(long), compare);
	int nc_index = 0;
	long bonussum = 0;
	for (int i = 0; i < NP; i++)
	{
		if (nc_index >= NC)
			break;
		if (products[i] < 0)
			break;
		long bonus = coupons[nc_index] * products[i];
		if (bonus < 0)
			break;
		bonussum += bonus;
		nc_index++;
	}
	nc_index = NC - 1;
	for (int i = NP - 1; i >= 0; i--)
	{
		if (nc_index < 0)
			break;
		if (products[i] > 0)
			break;
		long bonus = coupons[nc_index] * products[i];
		if (bonus < 0)
			break;
		bonussum += bonus;
		nc_index--;
	}
	cout << bonussum;
	return 0;
}

里面可以看到,某个监测点耗时还挺长的…不过我的原则是够用就好。如果优惠券数量远多于商品的话,考虑只对商品排序,然后找优惠券就行了;反之亦然。

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 1 256 10/10
1 答案正确 1 256 3/3
2 答案正确 1 352 3/3
3 答案正确 1 348 3/3
4 答案正确 53 2560 3/3
5 答案正确 1 356 3/3

 

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.